Drivers para arduino nano CH340 / CH340G / CH341

11 feb 2015 by shadow_of__soul, 12 Comments »

ArduinoNanoFront_3_sm

 

Arduino es una plataforma open source que tomo mucha popularidad por la comunidad maker, en este mismo blog hemos escrito algunos posts sobre el, y seguramente vendran mas. hay muchos tipos de arduino, cada uno con caracteristicas diferentes para aplicaciones diferentes. Entre las versiones disponibles, esta la nano, una de las mas chicas y accessibles. En la concepcion original del arduino nano, este usa un chip FTDI para hacer de interfaz USB  -> Serial para comunicarse con la placa. El tema es que como es open source y cualquier puede ensamblar y vender placas arduino, muchos vendedores en ebay y en china, cambiaron este chip por un CH340 / CH340G / CH341 que es mucho mas economico y funciona perfectamente. El problema surge que los drivers nativos que estan en arduino.cc , no funcionan. Por eso les traigo los drivers para este chip, que funciona perfectamente (solo probe la version de windows, ya que en linux me anduvo plug & play, no tengo mac, ni probe la version de android, aunque incluyo los otros que encontre por si a alguien le sirve).

Etiquetas: , ,

12 Comments

  1. FPaez.com dice:

    Gracias, me ha servido!

  2. Mike Patton dice:

    algún manual donde ver como cargarlo en android? saludos

  3. fontanares dice:

    Hola, recientemente compré un nano también con este chip (CH340G) y por mucho que lo he intentado no me funciona. He probado en Windows 10 64bit, Windows XP 32 bit, Windows 7 32 bits y en ninguno de ellos me ha funcionado. Al acceder a dispositivos de hardware no aparece ningún puerto COM y al instalar el driver aparece, al final, un aviso de que el driver ya estaba instalado.
    Al conectar el arduino nano al pc se enciande el led de power y parpadea el del pin13 que según he leido es loq ue debe hacer cuando está cargado el bootloader.
    Se os ocurre qué puede pasar o cómo lo puedo solucionar?
    Gracias!

    • fontanares dice:

      Hola de nuevo, lo acabo de solucionar.
      Iba a borrar el post pero creo que es mejor dejarlo por si a alguien le pasa como a mí, que le he dado mil vueltas sin probar lo más fácil.

      Era el cable….

      Un saludo a todos!

Leave a Reply

Sigueme !

Follow Me! Follow Me! Follow Me!